FAQ / Questions fréquentes


Questions et réponses :

• Dois-je installer des pilotes (drivers), si oui lesquels ?


Weneo se conforme à la norme USB CCID pour sa partie lecteur de cartes à puces. Weneo utilise le pilote (driver) générique CCID de Microsoft.

Ce driver est présent par défaut sous Windows Vista et Windows Seven, Windows 8, Windows 10, Windows Server 2008 et Windows Server 2012 : vous n'avez aucune installation à effectuer pour ces systèmes.
Pour Windows XP ou Windows Server 2003, ce pilote CCID peut être téléchargé automatiquement depuis Windows Update quand Weneo est branché sur votre ordinateur.

Néanmoins, les services de Windows Update ne sont pas toujours disponibles, aussi voici des installeurs indépendants "offline" que vous pouvez utiliser :
- Pour les éditions 32 bits de Windows XP / 2003 : usbccid_32bits.exe
- Pour les éditions 64 bits de Windows XP / 2003 : usbccid_64bits.exe

Note concernant Windows Server 2003 :
Même pour les fonctionnalités de Login Windows sécurisé par carte à puce commme proposées dans la gamme Weneo ID, il n'est pas nécessaire de brancher un Weneo sur le serveur (sauf éventuellement pour en sécuriser l'accès via un Weneo en local) et donc aucune installation n'est normalement nécessaire sur Windows Server 2003.

Retour au sommaire des questions

• Sous Windows Seven, "le pilote du périphérique n'a pas pu être installé"?


Ce message surgit de la barre des tâches Windows au branchement d'un Weneo sous Windows Seven (alors que Weneo ne nécessite aucun driver/pilote sous Windows Seven) ou au passage d'une carte sur un lecteur Weneo NFC branché.

Dans ces deux cas, il s'agit de l'option "SmartCard Plug and Play" de Windows Seven qui tente d'associer un middleware par défaut à une carte à puce détectée (ce que Windows Seven appelle maintenant abusivement un "pilote de carte à puce"). Le Weneo en lui même est pourtant convenablement installé :

Ce message perturbant (propre à Windows Seven) ne signale aucune véritable erreur et vous pouvez supprimer son apparition inutile en double-cliquant sur le fichier DisableWindows7Message.reg situé dans ce fichier zip.

Il s'agit d'une simple clef dans la registry à modifier et vous pouvez ouvrir ce fichier avec votre editeur préféré pour connaître la clef et faire votre propre patch si besoin. Le fichier zip contient aussi un fichier .reg pour réactiver l'apparition du message. Faire disparaitre ce message possède aussi l'avantage d'éviter une latence supplémentaire à chaque fois que votre installation Windows Seven découvre une nouvelle carte à puce.

Retour au sommaire des questions

• Quelles sont les fonctions de Weneo ?


Weneo est un « Smart Object », un objet intelligent doté d’une interface sans contact pour une utilisation comme une carte à puce sans contact classique (mode autonome) et d’un connecteur USB pour la connectivité au PC et à Internet (mode connecté).

La fonction « mémoire de masse » de Weneo permet à un PC d’accéder au contenu de sa mémoire flash, comme s’il s’agissait d’une clé USB classique. La fonction « lecteur » donne accès aux applications de la carte à puce intégrée dans Weneo.

Weneo NFC est un modèle spécial qui offre la fonctionnalité supplémentaire de lecteur sans contact quand il est branché en USB. Weneo NFC peut ainsi lire différentes cartes ou supports RFID/NFC dont Weneo.

Les produits de la gamme Weneo ID proposent diverses fonctionnalités comme le login par carte à puce en intégrant une solution logicielle dite "middleware".

Retour au sommaire des questions

• Quels sont les systèmes d’exploitation supportés ?


Weneo est entièrement compatible avec :

• Windows XP, Windows Server 2003 (installation des drivers ccid nécessaires)

• Windows Vista, Windows Seven, Windows 8, Windows 10, Windows Server 2008 et Windows Server 2012 (Aucun pilote/driver n'est nécessaire sous ces versions de Windows qui intègrent déjà le support de PCSC / CCID.)

• Mac OS X 10.7, 10.8, 10.9, 10.10 : "Plug and Play" : Aucun pilote nécessaire (pilote PCSC / CCID intégré à Mac OS X)

• Linux : Installer les paquets libccid, pcscd, libpcsclite et libpcsclite-dev

Retour au sommaire des questions

• Quels sont les navigateurs Internet (browsers) supportés ?


Certaines pages web contiennent une applet Java qui permet d'accéder à un Weneo pour l'interroger, le mettre à jour ou le recharger. Cette fonctionnalité est généralement compatible :
- sous Windows avec Internet Explorer, Mozilla Firefox et Chrome
- sous Mac Os X avec Safari et Mozilla Firefox (et Chrome)
- sous Linux avec Mozilla Firefox (et Chrome)

La fonctionnalité d'authentification par certificat SSL client (utilisation rare et spécifique) n'a été validée que sous Internet Explorer, Firefox, certaines versions de Chrome (Windows/Mac/Linux) et ne nécessite pas java.

Retour au sommaire des questions

• Quels sont les protocoles sans contact supportés ?


Pour les Weneo Standard, Pass, SIM et DUO, les protocoles sans contact supportés dépendent de la carte à puce intégrée dans Weneo. On peut donc avoir le support des protocoles standard ISO/IEC 14443 (Type A ou Type B) ainsi que le support d’autres protocoles (MIFARE, FeliCa, Innovatron).

Retour au sommaire des questions

• Quelles sont les applications carte à puce supportées ?


Les applications supportées dépendent de la carte à puce intégrée dans Weneo. Avec une carte à puce compatible Java Card, il est possible de développer ses propres applications. Certaines puces sont fournies avec des applications "bancaires" ou "Transport".

Les produits de la gamme Weneo ID proposent diverses fonctionnalités comme le login par carte à puce en intégrant une solution logicielle dite "middleware".

Retour au sommaire des questions

• Comment communiquer avec la carte à puce intégrée dans Weneo ?


Une fois que le pilote CCID est installé, une application Windows communique avec les applications de la carte à puce en utilisant les API PC/SC.

Retour au sommaire des questions

• A quoi sert Java ? Comment installer Java ?


La technologie Java d'Oracle est utilisée par certaines pages web pour communiquer avec Weneo pour effectuer une lecture et/ou mise à jour sur Internet.

L’installation de Java est normalement automatiquement effectuée à la volée lorsqu’il est requis par une page Web. Si ce n’est pas le cas, vous pouvez installer manuellement le JRE depuis le site officiel de Java/Oracle.

Version minimale supportée : Java Runtime Environment 8
(Pour votre propre sécurité, il est recommandé d'utiliser la dernière version de Java)


Fin des questions réponses.
Retour au sommaire des questions



Vous avez d'autres questions ?
Contactez notre support technique par mail support@neowave.fr ou via le formulaire de la page contact.